اطلاعیه

بستن
No announcement yet.

کانکشن pppoe روی مودم یا روی روتر ؟!

بستن
این موضوع بسته شده است.
X
X
 
  • فیلتر کردن
  • زمان
  • نمایش
Clear All
پست های جدید

  • کانکشن pppoe روی مودم یا روی روتر ؟!

    سلام
    یک مودم adsl دارم که به روتر سیسکو وصل هست و کانکشن PPPOE بر روی مودم ست شده و یک آیپی ایستا اینترنتی هم روی روتر ست شده.

    به نظرتون این بهتره یا اینکه بیام کانکشن pppoe را مستقیم بیارم روی روتر سیسکو ؟ اگر بیارم روی روتر سیسکو خوبیش اینه که دیگه نیازی به گرفتن آیپی ایستای اضافه نیست (چون در حالت قبل یکی باید روی مودم ست بشه )

    اگر بیارم روی سیسکو ، بعد از قطع شدن دوباره خودش خودکار وصل میشه ؟ بعد از کانکت شدن خودش route اضافه می کنه یا باید دستی روت های مربوط به pppoe را بزنم ؟

    مرسی

  • #2
    مشکل نداره روی سیسکو باشه
    این هم دستوراتش

    interface FastEthernet0/0
    no ip address
    no ip redirects
    no ip unreachables
    ip virtual-reassembly
    ip tcp adjust-mss 1452
    duplex auto
    speed auto
    pppoe enable
    pppoe-client dial-pool-number 1
    !

    interface Dialer1
    ip address negotiated
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication pap chap callin
    ppp pap sent-username cisco password sisco
    ppp chap hostname cisco
    ppp chap password sisco
    !
    ip route 0.0.0.0 0.0.0.0 Dialer1

    کامنت


    • #3
      مرسی
      پس خودش route پیشفرض ایجاد نمیکنه نه ؟
      اگر کانکشن قطع بشه خودش خودکار وصل میشه ؟ مثل زمانی که روی مودم هست ؟ آخه وقتی روی مودم باشه خودش خودکار درصورت قطع شدن وصل میشه
      من ۲ تا pppoe کلاینت میخوام روی روتر بزنم نباید مشکلی باشه نه ؟

      کامنت


      • #4
        شما باید براش بنویسید
        اگر 2 دارید باید از policy route استفاده کنید
        دستور route-map که مشخص کنید هر کدوم کجا بره
        البته اگر لود بالانس می خواین که می policy route نمی خواین و 2 تا روت می نویسید
        ip route 0.0.0.0 0.0.0.0 Dialer1
        ip route 0.0.0.0 0.0.0.0 Dialer2

        کامنت


        • #5
          مرسی
          اوکی روت ها رو دستی می زنم .
          پس من با خیال راحت کانکشن ppoe را بیارم روی سیسکو ؟ با همین دستوراتی که زحمتش را کشیدید ؟ دستور دیگه ای لازم نیست ؟ مثل مودم خودش بعد از قطع شدن تلاش می کنه خودکار وصل بشه ؟ موقع روشن شدن هم خودش کانکت میشه ؟

          مرسی لطف کردید

          کامنت


          • #6
            الان با خیال راحت بگی سیستم خاموش کنم بعد روشن من باشم میگم اندکی تامل جایز است! :d
            شما شروع کن مشکلی بود حل میشه انشااله

            کامنت


            • #7
              مرسی
              آقا یک سوال ! من 2 تا کانکشن pppoe میخوام بزنم و هر کدوم از مودم ها به یکی از اینترفیس های روتر وصله ، توی دستوراتی که شما برای pppoe نوشتید من جایی ندیدم که مشخص کرده باشه مثلا dialer1 از کدوم اینترفیس برای اتصال استفاده کنه و مثلا dialer2 از کدوم اینترفیس استفاده کنه !
              نکته دیگه اینکه user o pass کانکشن را کجای دستورات شما باید وارد کنم ؟!

              کامنت


              • #8
                گفته که
                interface FastEthernet0/0

                pppoe enable
                pppoe-client dial-pool-number 1
                interface FastEthernet0/1
                pppoe enable
                pppoe-client dial-pool-number 2

                interface Dialer1
                ppp chap hostname cisco
                ppp chap password sisco

                کامنت


                • #9
                  مرسی
                  یعنی با
                  pppoe-client dial-pool-number 1 مشخص میشه ؟ pppoe-client dial-pool-number 1 مربوط به Dialer1 و pppoe-client dial-pool-number 2 مربوط به Dialer2 ?

                  بجای cisco و sisco باید نام کاربری و رمز عبور را بنویسم یا بجای hostname و password ?

                  کامنت


                  • #10
                    اره
                    ببین یک کانفیگ کامل از سایت سیسکو

                    !

                    hostname PPPoE-Client
                    vpdn enable
                    !
                    vpdn-group 1
                    request-dialin
                    protocol pppoe
                    !
                    interface Ethernet0/0
                    description PPPoE interface
                    no ip address
                    half-duplex
                    pppoe enable group global
                    pppoe-client dial-pool-number 1
                    !
                    interface Dialer0
                    description PPPoE dialer interface
                    mtu 1400
                    ip address negotiated
                    encapsulation ppp
                    dialer pool 1
                    dialer-group 1
                    no cdp enable
                    ppp authentication pap callin
                    ppp pap sent-username PPPoE-Client password 0 cisco
                    ppp ipcp address accept
                    !
                    ip route 0.0.0.0 0.0.0.0 Dialer0

                    کامنت


                    • #11
                      Server example

                      Server example using server side only authentication
                      aaa new-model
                      aaa authentication ppp default local none
                      !
                      username test_user password 0 123
                      !
                      bba-group pppoe pppoe-server
                      virtual-template 1
                      !
                      interface Virtual-Template1
                      mtu 1492
                      ip unnumbered Loopback1
                      peer default ip address pool pppoe
                      ppp authentication chap
                      !
                      interface Virtual-Template1
                      mtu 1492
                      ip unnumbered Loopback1
                      peer default ip address pool pppoe
                      ppp authentication chap
                      !
                      interface FastEthernet0/0
                      no ip address
                      duplex auto
                      speed auto
                      pppoe enable group pppoe-server
                      !
                      interface Loopback1
                      ip address 6.6.6.6 255.255.255.255
                      !
                      ip local pool pppoe 2.2.2.2
                      Client example

                      interface Dialer1
                      ip address negotiated
                      ip mtu 1492
                      encapsulation ppp
                      dialer pool 1
                      ppp chap hostname test_user
                      ppp chap password 0 123
                      !
                      interface FastEthernet0/0
                      no ip address
                      duplex auto
                      speed auto
                      pppoe enable
                      pppoe-client dial-pool-number 1
                      end
                      Verification

                      Show ip interface brief

                      We can use the 'show ip interface brief command on a client to look for the dialer interface to be in the up state with an address defined.
                      R2#sh ip interface brief | i Dialer
                      Dialer1 2.2.2.2 YES IPCP up up
                      Debug pppoe

                      There are a number of debug commands for PPPoE. The most useful debugs are PPPoE events and errors.
                      R2#debug pppoe ?
                      data PPPoE data packets
                      elog PPPoE elogs
                      errors PPPoE protocol errors
                      events PPPoE protocol events
                      packets PPPoE control packets
                      Debug ppp authentication

                      The debug ppp authentication command will confirm if PPP authentication is working correctly. This example has a wrong username.
                      R2#debug ppp authentication
                      *Jul 14 23:34:09.170: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
                      *Jul 14 23:34:09.170: Vi1 CHAP: Using hostname from interface CHAP
                      *Jul 14 23:34:09.170: Vi1 CHAP: Using password from interface CHAP
                      *Jul 14 23:34:09.170: Vi1 CHAP: O RESPONSE id 1 len 30 from "test_user"
                      *Jul 14 23:34:09.170: Vi1 CHAP: I FAILURE id 1 len 25 msg is "Authentication failed"

                      http://leighfinch.net/cisco_wiki/index.php/Pppoe

                      کامنت

                      در حال انجام ...
                      X