اطلاعیه

بستن
No announcement yet.

روتینگ پلیسی در میکروتیک

بستن
این موضوع بسته شده است.
X
X
 
  • فیلتر کردن
  • زمان
  • نمایش
Clear All
پست های جدید

  • روتینگ پلیسی در میکروتیک

    با سلام

    دوستان من از دو ISP اینترنت گرفتم.

    الان می خوام کاربرها ها به دو گروه تقسیم کنم و هر گروه از یک ISP اینترنت بگیره.

    pppoe server راه انداختم و دو IP Pool مختلف برای دو گروه در نظر گرفتم.

    به صورت زیر

    IP Pool Group 1 192.168.3.0/28:ISP1
    IP Pool Group 2192.168.4.0/28:ISP2

    قسمت منگل
    add action=mark-connection chain=prerouting new-connection-mark="Group User1" src-address=192.168.3.0/28

    add action=mark-routing chain=prerouting connection-mark="Group User1" new-routing-mark="TO_ISP1
    --
    add action=mark-connection chain=prerouting new-connection-mark="Group User2" src-address=192.168.4.0/28

    add action=mark-routing chain=prerouting connection-mark="Group User1" new-routing-mark="TO_ISP2
    قسمت نت


    add action=masqurade chain-srcnat src-address=192.168.3.0/28
    add action=masqurade chain-srcnat src-address=192.168.4.0/28
    قسمت روتینگ

    add distance=1 dst.address=0.0.0.0/0 gateway=pppoe-out1 routing-mark="TO_ISP1
    add distance=1 dst.address=0.0.0.0/0 gateway=pppoe-out2 routing-mark="TO_ISP2

    در حال حاضر مشکل ایت هست که کاربرها به pppoe server کانکت می شوند اما به اینترنت کانکت نمیشوند.

    دوستان کجای سناریو مشکل دارد.
    آخرین ویرایش توسط رضا قاسمی; در تاریخ/ساعت 2014/02/10, 05:38 PM.

  • #2
    ببینید شما بیاید توی قسمت روت و تب رول اونجا یک رول بسازید و سورستون رو توش اضافه کنید
    و برای هر دسته از کاربران یک رول حجداگانه بسازید توی قسمت روتینگ مارک هم toisp1 , toisp2
    رو برای هر رول جداگانه قرار بدید
    بعد هم توی تب روت یک روت بنویسید که اگر dst اون 0.0.0.0/0 بود و روتینگ مارکش to isp1 بود
    گیتویش بشه ip مودم ads اول و برای دومی هم همینکارو بکنید حتما جواب میده . تنظیمات dns
    روی روتر فراموش نشه

    توی چیزی که نوشتید کانکشن مارک رو به جای group user1 دادید grup user 10توی خط
    دوم و چهارم این اشتباه رو انجام دادید
    شرکت شبکه گستر پارسین
    09123514173

    کامنت


    • #3
      ممنون از پاسخ گویی شما
      خط دوم و چهارم خطای نوشتاری بود در تاپیک که اصلاح شد.
      در مورد اضافه کردن در قسمت route و تب rule به جز src.address باید چه آیتم دیگه تنظیم بشه؟

      بعد هم توی تب روت یک روت بنویسید که اگر dst اون 0.0.0.0/0 بود و روتینگ مارکش to isp1 بود
      گیتویش بشه ip مودم ads اول و برای دومی هم همینکارو بکنید.


      این کار رو کردم ببینید.
      add distance=1 dst.address=0.0.0.0/0 gateway=pppoe-out1 routing-mark="TO_ISP1
      آخرین ویرایش توسط رضا قاسمی; در تاریخ/ساعت 2014/02/10, 05:40 PM.

      کامنت


      • #4
        نوشته شده توسط رضا قاسمی مشاهده پست
        ممنون از پاسخ گویی شما
        خط دوم و چهارم خطای نوشتاری بود در تاپیک که اصلاح شد.
        در مورد اضافه کردن در قسمت route و تب rule به جز src.address باید چه آیتم دیگه تنظیم بشه؟
        چیز دیگه ایی نمی خواد
        همون کافیه
        شرکت شبکه گستر پارسین
        09123514173

        کامنت


        • #5
          باز جواب نداد .
          شما گفتید
          توی قسمت روت و تب رول اونجا یک رول بسازید و سورستون رو توش اضافه کنید
          و برای هر دسته از کاربران یک رول حجداگانه بسازید
          من این رو که اضافه کردم رکورد به صورت قرمز رنگ هست ظاهرا مشکل داره.
          ip route rule add src-address=192.168.3.0/28

          کامنت


          • #6
            نوشته شده توسط رضا قاسمی مشاهده پست
            باز جواب نداد .
            شما گفتید
            توی قسمت روت و تب رول اونجا یک رول بسازید و سورستون رو توش اضافه کنید
            و برای هر دسته از کاربران یک رول حجداگانه بسازید
            من این رو که اضافه کردم رکورد به صورت قرمز رنگ هست ظاهرا مشکل داره.
            ip route rule add src-address=192.168.3.0/28
            شما زدید 28/ امیدوارم که اشتباه تایپی باشه . اگر ممکنه یک تصویر از تنظیمات بزاریدبنده ببینم
            از بخش روت ادرس ppp مربوز به کانکشن اینترنت و ...
            شرکت شبکه گستر پارسین
            09123514173

            کامنت


            • #7








              کامنت


              • #8
                اگر براتون امکانش هست دسترسی بدید من چک کنم
                شرکت شبکه گستر پارسین
                09123514173

                کامنت


                • #9
                  اول اینکه توی IP Pool این نحوه نوشتن اشتباهه --> 192.168.3.0/24
                  بلکه باید بازه IPهاتو به این صورت تعریف کنی --> 192.168.3.200-192.168.3.20

                  دوم اینکه وقتی داری PPP Profile رو تعریف می کنی Local IP رو باید یه IP تو بازه کاربرای PPP بدی، مثلا در مورد سناریوی شما میتونی بدی: 192.168.3.1. یادت باشه این IP رو جز IPهای Pool قرار ندی.

                  در مورد مشکل اصلیت هم نکته ش اینجاس که وقتی توی روت پالیسی SourceIPها رو مشخص می کنی اون پایین تو قسمت Table باید یه اسم بهش بدی، مثلا Group1. بعد توی Route وقتی میخوای 0.0.0.0 رو برای گروه مورد نظر به سمت Gateway مربوطه Route کنی، Routing Mark رو باید برابر اون اسم مشخص شده توی Table قرار بدی (Group1).
                  البته اگه از این روش استفاده می کنی دیگه از Mangle بی نیاز میشی. Masq هم فراموش نشه. و من الله توفق
                  آخرین ویرایش توسط Hadi_020; در تاریخ/ساعت 2014/02/11, 02:15 AM.

                  کامنت


                  • #10
                    می تونید از رول های زیر کمک بگیرید من دقیقا همین سناریو را انجام دادم.
                    در این سناریو dsl به صورت pppoe client روی میکروتیک تنظیم شده است و به کاربر ها از طریق pppoe server اینترنت داده می شود.

                    ip pool
                    add name="POOL USERS DSL 1" ranges=192.168.3.2-192.168.3.250
                    add name="POOL USERS DSL 2" ranges=192.168.4.2-192.168.4.250


                    ip firewall address-list
                    add address=192.168.3.0/24 disabled=no list=DSL1_USERS_LIST
                    add address=192.168.4.0/24 disabled=no list=DSL2_USERS_LIST

                    ip firewall mangle
                    add action=mark-routing chain=prerouting disabled=no new-routing-mark=wan1_user passthrough=no src-address-list=DSL1_USERS_LIST
                    add action=mark-routing chain=prerouting disabled=no new-routing-mark=wan2_user passthrough=no src-address-list=DSL2_USERS_LIST

                    /ip route
                    add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out-wan1 routing-mark=wan1_user scope=30 target-scope=10
                    add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out-wan2 routing-mark=wan2_user scope=30 target-scope=10


                    /ip firewall nat
                    add action=masquerade chain=srcnat disabled=no src-address=192.168.3.0/24
                    add action=masquerade chain=srcnat disabled=no src-address=192.168.4.0/24

                    کامنت


                    • #11
                      لبته راه حل دقیقا همینه و راه حل های متفاوت دیگه ایی هم هست . اما تنظیمات روتر این دوستمون انقدر پیچیده و شلوغ هستش
                      که من نتونستم براشون راه اندازی کنم
                      شرکت شبکه گستر پارسین
                      09123514173

                      کامنت

                      در حال انجام ...
                      X