ShirazOnline hotspotplus
صفحه 1 از 3 123 آخرینآخرین
نمایش نتایج: از شماره 1 تا 10 , از مجموع 25

موضوع: آموزش راه اندازی mpls

  1. #1
    کاربر مستعد nimabagheri آواتار ها
    تاریخ عضویت
    Dec 2008
    محل سکونت
    Iran : kARaJ
    نوشته ها
    954
    تشکرها / پسندها

    پیش فرض آموزش راه اندازی mpls

    با توجه به درخواست یکی از دوستان برای راه اندازی MPLS نشستم و سعی کردم تا اونجا که میدونم خیلی ساده این تنظیمات رو ارایه بدم .
    خوب بهتره بریم سر اصل مطلب راه اندازی MPLS :
    ۱- ما در این سناریو بوسیله VPN BGP Over OSPF راهاندازی کردیم .
    ۲- سعی میکنم در چند تا پست این سناریو رو جلو ببرم . چون یه ذره دستوراتش زیاده و منم وقتم محدود .
    ۳- ما در این طرح روترهای R3,R4,R5 رو بعنوان روترهای مخابرات(Provider) در نظر میگیریم .
    طرح مربوطه رو lمیتونید از آدرس زیر بگیرید .
    [فقط اعضا می توانند لینک ها را مشاهده کنند برای ثبت نام اینجا را کلیک کنید]

    خوب در این طرح در گام اول ما به تمامی روتر ها IP داده بطور مثال
    ًR1
    en
    conf t
    int f0/0
    ip add 192.168.1.1 255.255.255.0.
    no shut
    int s1/0
    ip add 200.1.1.1 255.255.255.0
    no shut


    R2

    en
    conf t
    int f0/0
    ip add 192.168.1.1 255.255.255.0.
    no shut
    int s1/0
    ip add 200.1.2.1 255.255.255.0
    no shut

    همین کار را در روترهای R6,R7 انجام میدهیم .بدین صورت به تمامی روتر ها یک IP داده و ارتباط اولیه را برقرار میکنیم .و یک Default Route میزنیم به سمت روتر های Edge.(برای این کلیه دستورات رو ننوشتم چون زیاد بود )
    از این به بعد کار اصلی شروع میشه .
    در گام اول ما میبایست Routing protocol OSPF رو ما بین روترهای R3,R4,R5 راه اندازی کنیم .برای اینکه روتینگ ما Stable تر باشه ما میاییم و یک اینترفیس Loopback در تمام روتر های ابر mpls ایجاد میکنیم . و به هر اینرفیس لوپبک یک IP اختصاص میدهیم
    بطور مثال :
    R3
    en
    conf t
    int loopback 0
    ip address 10.1.1.1 255.255.255.255

    R4
    en
    conf t
    int loopback 0
    ip address 10.1.1.2 255.255.255.255

    R5
    en
    conf t
    int loopback 0
    ip address 10.1.1.3 255.255.255.255

    بعد از این کار ما میاییم مابین روترهای ذکر شده در بالا OSPF راه اندازی میکنیم و شبکه های مابین Provider ها را به روتر ها میشناسانیم .
    R3

    Router ospf 1
    Network "Ip S1/2" wildcard area 0
    network "Ip Loopback" 0.0.0.0 area 0

    R4

    Router ospf 1
    Network "Ip S1/0" wildcard area 0
    Network "Ip S1/1" wildcard area 0
    network "Ip Loopback" 0.0.0.0 area 0


    R5

    Router ospf 1
    Network "Ip S1/2" wildcard area 0
    network "Ip Loopback" 0.0.0.0 area 0

    بعد از این دستورات باید ارتباط ما بین روتر های Provider برقرار باشه . و روتینگ Table اینها کامل باشه .

    بعد ازانجام این کارها ما میریم سراغ استارت زدن موتور MPLS در روتر های Provider .
    برای این کار در کلیه روتر های R3,R4,R5 دستورات زیر را میزنیم . در محیط کانفیگ ترمینال

    R3
    en
    conf t
    ip cef
    mpls lable protocol LDP
    mpls ldp router-id loopback 0
    int s1/2
    mpls ip

    R4
    en
    conf t
    ip cef
    mpls lable protocol LDP
    mpls ldp router-id loopback 0
    int s1/0
    mpls ip
    int s1/1
    mpls ip

    R5
    en
    conf t
    ip cef
    mpls lable protocol LDP
    mpls ldp router-id loopback 0
    int s1/2
    mpls ip

    با دستورات show mpls ldp binding, show mpls forwarding table میتوانید از سحت برقراری ارتباط MPLS اطمینان حاصل کنید .
    به یاد داشته باشید که در پروژه های این چنینی( بزرگ )‌باید Step by Step حرکت کرد .

    تا اینجا ارتباط اولیه برقرار شد . هر کی تا اینجا سوال داره بپرسه وگرنه فردا میریم سراغ قسمت بعدی .
    ویرایش توسط nimabagheri : 2010/05/18 در ساعت 04:45 PM
    فقط برای پروژه
    ۰۹۳۶۲۰۹۴۰۰۳


  2. Thanks mms2565 thanked for this post
  3. # ADS
    Circuit advertisement
    تاریخ عضویت
    Always
    محل سکونت
    Advertising world
    نوشته ها
    Many
     

  4. #2
    کاربر عادی i.mansouri آواتار ها
    تاریخ عضویت
    Feb 2009
    نوشته ها
    96
    تشکرها / پسندها

    پیش فرض

    بله اما چند تا نکته مهم »

    1. اولا که VPN BGP Over OSFP اصلاح کاملا غلطی است. مفهوم Over به چیز دیگه است. MPLS VPN ، MP-BGP یک چیز است. OSPF و IS-IS تنها IGP هایی هستند که در شبکه Core مربوط MPLS از آنها استفاده می شود . می توان که MPLS داشت حتی بدون BGP که بهش می گن BGP Core Free ... که فقط از Labling مربوط به MPLS استفاده می شود. به این می گن MPLS VPN
    2. در مورد loop back interface باید که حتما /32 باشد. چرا ؟ برای اینکه به عنوان LDP router id از ان استفاده می شود.
    3. فرمان mpls ldp protocol ldp نیاز نیست ، برای اینکه default است.
    4. فرمان mpls ip هم در سطح interface و هم در سطح روتر باید زده بشود. به دلیل رفتار مختلف IOS های مختلف
    5. بعد هم از ابن دو تا فرمان برای صحت برقراری ارتباط استفاده نمی شود. اولین فرمان show mpsl ldp neighbor و show mpls ldp discovery هست. از فرمان show mpls ldp binding برای دیدن LIB و از show mpls ldp ip binding برای دیدن LFIB استفاده می شود. حتی می توان از فرمان show ip cef برای دیدن LFIB استفاده کرد.

    با اآرزوی موفقیت !!!!
    [فقط اعضا می توانند لینک ها را مشاهده کنند برای ثبت نام اینجا را کلیک کنید] :: i.mansouri@mynetnote.net

  5. Thanks babakbm thanked for this post
  6. #3
    کاربر مستعد nimabagheri آواتار ها
    تاریخ عضویت
    Dec 2008
    محل سکونت
    Iran : kARaJ
    نوشته ها
    954
    تشکرها / پسندها

    پیش فرض

    نقل قول نوشته اصلی توسط i.mansouri نمایش پست ها
    بله اما چند تا نکته مهم »

    1. اولا که VPN BGP Over OSFP اصلاح کاملا غلطی است. مفهوم Over به چیز دیگه است. MPLS VPN ، MP-BGP یک چیز است. OSPF و IS-IS تنها IGP هایی هستند که در شبکه Core مربوط MPLS از آنها استفاده می شود . می توان که MPLS داشت حتی بدون BGP که بهش می گن BGP Core Free ... که فقط از Labling مربوط به MPLS استفاده می شود. به این می گن MPLS VPN
    2. در مورد loop back interface باید که حتما /32 باشد. چرا ؟ برای اینکه به عنوان LDP router id از ان استفاده می شود.
    3. فرمان mpls ldp protocol ldp نیاز نیست ، برای اینکه default است.
    4. فرمان mpls ip هم در سطح interface و هم در سطح روتر باید زده بشود. به دلیل رفتار مختلف IOS های مختلف
    5. بعد هم از ابن دو تا فرمان برای صحت برقراری ارتباط استفاده نمی شود. اولین فرمان show mpsl ldp neighbor و show mpls ldp discovery هست. از فرمان show mpls ldp binding برای دیدن LIB و از show mpls ldp ip binding برای دیدن LFIB استفاده می شود. حتی می توان از فرمان show ip cef برای دیدن LFIB استفاده کرد.

    با اآرزوی موفقیت !!!!

    مرسی از توجتهون و اینکه بابت اصلاحات ممنون .
    اسمی که گفتم رو بخاطر این انتخاب کردم که بگم دارم از چه روشی جلو میرم از vpn بر روی Bgp در حالی که ارتباط بین روتر های provider از طریق OSPF هستش .
    منظورم از صحت برقراری ارتباط همون LIBو LFIB بود (البته الان که نوشتم رو نگاه کردمدیدم بد نوشتم )
    فقط برای پروژه
    ۰۹۳۶۲۰۹۴۰۰۳


  7. Thanks mms2565 thanked for this post
  8. #4
    کاربر مستعد nimabagheri آواتار ها
    تاریخ عضویت
    Dec 2008
    محل سکونت
    Iran : kARaJ
    نوشته ها
    954
    تشکرها / پسندها

    پیش فرض

    ًخوب در پست قبلی ما استارت MPLS رو زدیم . اما تا اینجا کاره ما تموم نشده .
    ما میریم سراغ راه اندازی BGP بر روی OSPF و داخل BGP ارتباط ما بین شعبات رو مشخص میکنیم .

    در اینجا کار ما با روتر R4(روتر مرکزی Provider ) تموم شده . بعد از این تنظیمات را در روتر های R3,R5(روتر های Edge) انجام میدهیم .
    ما اول احتیاج داریم که همسایه هارو معرفی کنیم در روترهای Edge . برای این کار از دستورات زیر استفاده میکنیم .

    R3
    en
    conf t
    ipvrf sherkatx
    rd "Asn:nn"or"ipaddress:nn"
    router-target both "Asn:nn"or"ipaddress:nn"
    ipvrf sherkaty
    rd "Asn:nn"or"ipaddress:nn"
    router-target both "Asn:nn"or"ipaddress:nn"

    R5
    en
    conf t
    ipvrf sherkatx
    rd "Asn:nn"or"ipaddress:nn"
    router-target both "Asn:nn"or"ipaddress:nn"
    ipvrf sherkaty
    rd "Asn:nn"or"ipaddress:nn"
    router-target both "Asn:nn"or"ipaddress:nn"


    بعد از تعریف همسایه ها می بایست بر روی اینترفیس های سمت شعبات نیز این VRF مشخص شود .بطور مثال در روتر R3 این تنظیمات راانجام میدهیم .(همین کار را با روتر R5 نیز باید انجام داد )
    R3
    int s1/0
    IP VRF forwarding sherkatx
    ip address x.x.x.x y.y.y.y
    int s1/1
    ip vrf forwarding sherkaty
    ip address x.x.x.x y.y.y.y
    سپس با دستورات show ip vrf sherkatx میتوانیمdefault RD , interface را ببینیم.
    و با دستور ping vrf sherkatx ip اینترفیس vrf را پینگ کنیم .
    بعد از این کار ما باید این دو ip جدید را برای روتر مشخص کنیم که از کجا آمده (و به کجا خواهد رفت )این کار را در روتر R5 نیز انجام میدهیم .
    ip route vrf sherkatx destinationip

    ip route vrf sherkaty destinationip

    در گام بعدی نیاز به راه اندازی BGPبین روتر های R3,R5 داریم .
    R3
    en
    conf t
    router bgp 100
    neighbor "ip address" local-as 100
    neighbor "ip address" update-source loopback0

    تا اینجا ما BGP رو بر روی OSPF راه اندازی کردیم و اینکه همسایه های روتر Edge رو هم مشخص کردیم . ان شاالله در پست بعدی دوگام آخر و نهایی رو بیان میکنیم تا راه اندازی MPLS هم تموم شه .
    یه نکته داخل پرانتز بگم (اگه ایرادی داشتم توی بیان موضوع شما به بزرگواریه خودتون ببخشید )
    موفق باشید .




    فقط برای پروژه
    ۰۹۳۶۲۰۹۴۰۰۳


  9. Thanks mms2565 thanked for this post
  10. #5
    کاربر مستعد nimabagheri آواتار ها
    تاریخ عضویت
    Dec 2008
    محل سکونت
    Iran : kARaJ
    نوشته ها
    954
    تشکرها / پسندها

    پیش فرض

    با سلام مجدد
    خوب توی این پست دو بخش آخر رو هم بگیم که دیگه راه اندازی mpls تموم بشه (البته فقط راه اندازیش)
    ما توی پستهای قبلی bgp رو هم راه اندازی کردیم . حالا میریم سراغ تنظیمات vpn در bgp .برای راه اندازی vpn باید دستورات زیر را بزنیم .
    R3
    en
    conf t
    router bgp 100
    address-family vpnv4
    neighbor "ip address" activate
    neighbor "ip address" send-community both
    دستورات بالا را برای روتر R5 هم میزنیم .

    بعد از راه اندازی VPNv4 نوبت به تنظیمات ipv4 در BGP میرسه که بادستورات زیر این کار رو انجام میدیم . عینا این دستورات را در روتر R5 نیز میزنیم .
    R3
    en
    conf t
    router bgp 100
    address-family ipv4 vrf sherkatx
    redistribute connected
    redistribute static
    address-family ipv4 vrf sherkaty
    redistribute connected
    redistribute static

    و این هم دستورات آخر برای راه اندازی MPLS امیدوارم که مفید بوده باشه .

    با آرزوی موفقیت .


    فقط برای پروژه
    ۰۹۳۶۲۰۹۴۰۰۳


  11. Thanks mms2565 thanked for this post
  12. #6
    کاربر فعال ramin_malek آواتار ها
    تاریخ عضویت
    Sep 2007
    محل سکونت
    Server Room
    نوشته ها
    1,212
    تشکرها / پسندها

    پیش فرض

    شکر رسمی داشت این نه دکمه ای

  13. Thanks mms2565 thanked for this post
  14. #7
    کاربر فعال sepehr912 آواتار ها
    تاریخ عضویت
    Jan 1970
    محل سکونت
    0.0.0.0/32
    نوشته ها
    1,892
    تشکرها / پسندها

    پیش فرض

    نقل قول نوشته اصلی توسط ramin_malek نمایش پست ها
    شکر رسمی داشت این نه دکمه ای
    چی؟
    Mohsen Bayatani
    sepehr912@yaho

  15. #8
    Super Moderator patris_70 آواتار ها
    تاریخ عضویت
    Jan 1970
    نوشته ها
    6,863
    تشکرها / پسندها

    پیش فرض

    منظورشون اینه که باید نوشتنی تشکر کرد نه اینکه از دگمه تشکر استفاده کرد.
    داخل انجمن سوال کنید تا دیگران هم اگر مشکل شما را دارند یا برایشان در آینده پیش بیاید استفاده کنند. پیغام خصوصی برای جواب دادن به سوال نیست.

  16. #9
    کاربر عادی sound آواتار ها
    تاریخ عضویت
    Sep 2008
    نوشته ها
    193
    تشکرها / پسندها

    Icon Sad کمک فوری در مورد راه اندازی mpls

    دیتا استان تهران برای راه اندازی mpls به من گفته باید یک مودم adsl استفاده کنم.
    برای من لایه 3 تعریف کردن و wan ip و lan ip هم بهم داده.
    ولی نمدونم باید چطوری از این ipها استفاده کنم.
    Wan ip:172.17.17.92/30
    lan ip:192.168.12.0/24
    طرف دوم هم سیستم تلبس که به راحتی کانفیگ کردم و کار میکنه.
    ممنونم از دوستان که بتونن منو راهنمایی کنن.

  17. #10
    کاربر عادی ahead آواتار ها
    تاریخ عضویت
    Oct 2008
    نوشته ها
    3
    تشکرها / پسندها

    پیش فرض

    با تشکر...
    آقا فایلش رو دوباره آپلود کن....

صفحه 1 از 3 123 آخرینآخرین

اطلاعات موضوع

کاربرانی که در حال مشاهده این موضوع هستند

در حال حاضر 1 کاربر در حال مشاهده این موضوع است. (0 کاربران و 1 مهمان ها)

علاقه مندی ها (Bookmarks)

علاقه مندی ها (Bookmarks)

مجوز های ارسال و ویرایش

  • شما نمیتوانید موضوع جدیدی ارسال کنید
  • شما امکان ارسال پاسخ را ندارید
  • شما نمیتوانید فایل پیوست کنید.
  • شما نمیتوانید پست های خود را ویرایش کنید
  •